SSL Vulnerability

As many of you know, a serious vulnerability in OpenSSL cryptographic software library was recently discovered: CVE-2014-0346 / CVE-2014-0160, commonly called the "Heartbleed Bug." This vulnerability is described at http://heartbleed.com.


We are working across all servers and products to ensure that any vulnerabilities are addressed as soon as possible.  The vast majority of our systems have already been updated with patches and we will be replacing the SSL certificates soon.  You may notice an interruption in service is you are online when changes are made.

Login or Signup to post a comment